PhotoshopNews.com
Dec 15, 2006

Minimum System Requirements to run the Photoshop CS3 Beta

To run the CS3 beta on Mac, you will need to have Mac OS X 10.4.8. To run the beta on Windows, you’ll need to have Windows XP SP2 or Vista. Read on for full minimum system requirements…

Macintosh
PowerPC® G4 or G5 or Intel based Macintosh processor
Mac OS X v.10.4.8
320MB of RAM (512MB recommended)
512 minimum of RAM if you are running Adobe Bridge as well
64MB of video RAM
1.5GB of available hard-disk space
1,024×768 monitor resolution with 16-bit video card
DVD-ROM drive
Internet or phone connection required for product activation
QuickTime 7 software required for multimedia features

Windows
Intel® Pentium® 4, Intel Centrino®, Intel Xeon®, or Dual-Core Intel Xeon processor
Microsoft® Windows® XP with Service Pack 2 or Windows Vista™
320MB of RAM (512MB recommended)
512 minimum of RAM if you are running Adobe Bridge as well
64MB of video RAM
650MB of available hard-disk space
1,024×768 monitor resolution with 16-bit video card
DVD-ROM drive
Internet or phone connection required for product activation
QuickTime 7 software required for multimedia features

So, no…no backwards compatibility to older operating systems and for a very good reason. Photoshop CS3 is intended to be delivered in Spring, 2007 and by that time Vista and OS X 10.5 (Leopard) will be the current shipping major OS’s. The feature set and functionality of CS3 requires system level services found only in the more recent versions of the operating systems.

Comments are closed.